Ergebnis 1 bis 5 von 5

Thema: ASSP Version: 1.9.1.1 / Exchange SBS 2003 / web.de

  1. #1
    Neues Mitglied
    Registriert seit
    20.06.2011
    Beiträge
    2

    Frage ASSP Version: 1.9.1.1 / Exchange SBS 2003 / web.de

    Hallo zusammen,

    ich betreibe einen kleinen privaten Emailserver auf Basis von Exchange 2003 (SBS 2003). Da ich von meinen Internet Provider keine fest IP Adresse vergeben bekomme, habe ich bei meinem Domänen Provider den ersten MX Eintrag auf ein dynamische Adresse legen lassen.

    Hier hatte ich dann vor Jahren das erste mal Probleme mit web.de. Nach kurzer Recherchephase habe ich dann im SMTP Connector den Smarthost und die Anmeldung bei meinem Domänen Provider eingetragen.

    Jetzt konnte ich ohne Probleme auch an web.de Emails versenden.

    Die Zeit verstrich, und SPAM wurde mehr

    Ich habe mich dann für ASSP entschieden. Das war vor ca. 2 Jahren. Die eingehenden Emails wurden auch - für meinen Geschmack - sauber gefiltert. Sicherlich könnte man hier noch mehr erzielen, aber für mich war das OK.

    Nachdem ich aber in letzter Zeit in meinem Outlook immer wieder Emails im Junk-E-Mail Ordner gefunden habe, habe ich in Foren nochmals nachgefragt. Ich bekam dort die Antwort mit der Emailweiterleitung als Anhang an "assp-spam AT assp.local".

    So weit so gut. Also Email weitergeleitet und .... nix passiert.

    In der Zwischenzeit habe ich das jetzt am Laufen.


    Hier mal stylistisch aufgezeigt. Zur Info. Alles läuft auf einem Server mit der IP 192.168.192.123 / Servername = S1.vhs.local

    INBOUND:

    Internet 25 -> 25(in) [Router] 2525(out) -> 2525(in = SMTP Listen Port) [ASSP] 26(out = SMTP Destination) -> 26(in) [Default SMTP Virtual Server auf Exchange 2003] -> [Exchange Server 2003] -> Outlook 2010

    OUTBOUND:

    Outlook 2010 -> [Exchange Server 2003] -> [Default SMTP Virtual Server auf Exchange 2003] 125(out) -> 125(in = Relay Port) [ASSP] 126(out = Relay Host) -> 126(in) [ASSP Relay SMTP Virtual Server auf Exchange 2003] 25(out) -> [SMTP Connector zu webhoster.de auf Exchange 2003 mit Smarthosteintrag und Benutzeranmeldung] -> Internet

    Ich kann in dieser Konstellation Emails empfangen und versenden.

    Nur beim Versand von Emails zu web.de habe ich Probleme.

    Erst wurden diese Emails gar nicht zugestellt. Auf Grund einer Fehlermeldung dachte ich, dass die Benutzerauthentifizierung hier umgangen wird. Da ASSP unter Relaying mir jedoch die Punkte bietet, habe ich die Felder

    -> Username for Authentication to Relay Host
    -> Password for Authentication to Relay Host
    -> ISP/Secondary MX Servers

    zusätzlich zu [SMTP Connector zu webhoster.de auf Exchange 2003 mit Smarthosteintrag und Benutzeranmeldung] ausgefüllt.

    In der Zwischenzeit kann ich Emails an web.de versenden, erhalte jedoch trotzdem folgende Fehlermeldung:

    Code:
    Reporting-MTA: dns; fmmailgate01.web.de
    X-Postfix-Queue-ID: AC118191D3A88
    X-Postfix-Sender: rfc822; info AT meinefqdn.de.de
    Arrival-Date: Tue, 21 Jun 2011 08:36:26 +0200 (CEST)
    
    Final-Recipient: rfc822; info AT meinefqdn.de.de
    Original-Recipient: rfc822;info AT meinefqdn.de.de
    Action: failed
    Status: 5.7.1
    Remote-MTA: dns; vhs.no-ip.info
    Diagnostic-Code: smtp; 554 5.7.1 Mail (30863-00106) appears to be unsolicited -
        No Spoofing Allowed - send error reports to postmaster AT meinefqdn.de.de
    Hier anbei noch die Logdateien von meinen beiden virtuellen SMTP Servern:

    Code:
    1. Log vom [Default SMTP Virtual Server auf Exchange 2003]
    
    192.168.192.123, OutboundConnectionResponse, 21.06.2011, 08:20:41, SMTPSVC1, S1, -, 91, 0, 112, 0, 0, -, -, 220 s1.vhs.local Microsoft ESMTP MAIL Service, Version: 6.0.3790.4675 ready at  Tue, 21 Jun 2011 08:20:41 +0200 ,
    192.168.192.123, OutboundConnectionCommand, 21.06.2011, 08:20:41, SMTPSVC1, S1, -, 91, 0, 4, 0, 0, EHLO, -, s1.vhs.local,
    192.168.192.123, OutboundConnectionResponse, 21.06.2011, 08:20:41, SMTPSVC1, S1, -, 91, 0, 40, 0, 0, -, -, 250-s1.vhs.local Hello [192.168.192.123],
    192.168.192.123, OutboundConnectionResponse, 21.06.2011, 08:20:41, SMTPSVC1, S1, -, 281, 0, 20, 0, 0, -, -, 334 GSSAPI supported,
    192.168.192.123, OutboundConnectionResponse, 21.06.2011, 08:20:41, SMTPSVC1, S1, -, 291, 0, 224, 0, 0, -, -, 334 oYGgMIGdoAMKAQChCwYJKoZIgvcSAQICooGIBIGFYIGCBgkqhkiG9xIBAgICAG9zMHGgAwIBBaEDAgEPomUwY6ADAgEXolwEWug22mm0f9Wch0cMm9p+qe7sASQ2guTfHuk9Mvt8yPWZO9LkEERWy+UyJ+ySmS7QbeiI6FAtzJBgk4LybvGZrqmQuSrhf4eyUNRqLmCohEK0HOWuaxHwk8/ZKQ==,
    192.168.192.123, OutboundConnectionResponse, 21.06.2011, 08:20:41, SMTPSVC1, S1, -, 291, 0, 36, 0, 0, -, -, 235 2.7.0 Authentication successful.,
    192.168.192.123, OutboundConnectionCommand, 21.06.2011, 08:20:41, SMTPSVC1, S1, -, 291, 0, 12, 0, 0, X-LINK2STATE, -, LAST CHUNK={0000006a} MULTI (5) ({00000051} DIGEST_QUERY 32c553cfde95fd4d8a6c68d1dc04baab d8e1d9c163a2acb2f9f0de515e0e5287  )  ,
    192.168.192.123, OutboundConnectionResponse, 21.06.2011, 08:20:41, SMTPSVC1, S1, -, 301, 0, 66, 0, 0, -, -, 200 LAST CHUNK={00000029} MULTI (5) ({00000010} DONE_RESPONSE  )  ,
    192.168.192.123, OutboundConnectionCommand, 21.06.2011, 08:20:41, SMTPSVC1, S1, -, 301, 0, 4, 0, 0, MAIL, -, FROM:<it AT meinefqdn.de>,
    192.168.192.123, OutboundConnectionResponse, 21.06.2011, 08:20:41, SMTPSVC1, S1, -, 311, 0, 41, 0, 0, -, -, 250 2.1.0 it AT meinefqdn.de....Sender OK,
    192.168.192.123, OutboundConnectionCommand, 21.06.2011, 08:20:41, SMTPSVC1, S1, -, 311, 0, 4, 0, 0, RCPT, -, TO:<meine.email AT web.de> NOTIFY=SUCCESS,FAILURE,DELAY,
    192.168.192.123, OutboundConnectionResponse, 21.06.2011, 08:20:41, SMTPSVC1, S1, -, 311, 0, 37, 0, 0, -, -, 250 2.1.5 meine.email AT web.de ,
    192.168.192.123, OutboundConnectionCommand, 21.06.2011, 08:20:41, SMTPSVC1, S1, -, 311, 0, 4, 0, 0, DATA, -, -,
    192.168.192.123, OutboundConnectionResponse, 21.06.2011, 08:20:41, SMTPSVC1, S1, -, 321, 0, 44, 0, 0, -, -, 354 Start mail input; end with <CRLF>.<CRLF>,
    192.168.192.123, OutboundConnectionResponse, 21.06.2011, 08:20:41, SMTPSVC1, S1, -, 761, 0, 89, 0, 0, -, -, 250 2.6.0  <E146B2C65166FF4E82295F45E34A76A614C174 AT s1.vhs.local> Queued mail for delivery,
    192.168.192.123, OutboundConnectionCommand, 21.06.2011, 08:20:41, SMTPSVC1, S1, -, 802, 0, 4, 0, 0, QUIT, -, -,
    192.168.192.123, OutboundConnectionResponse, 21.06.2011, 08:20:41, SMTPSVC1, S1, -, 802, 0, 59, 0, 0, -, -, 221 2.0.0 s1.vhs.local Service closing transmission channel,
    192.168.192.123, ASSP.local, 21.06.2011, 08:20:45, SMTPSVC1, S1, 192.168.192.123, 0, 15, 307, 250, 0, EHLO, -,  ASSP.local,
    192.168.192.123, ASSP.local, 21.06.2011, 08:20:45, SMTPSVC1, S1, 192.168.192.123, 0, 40, 43, 250, 0, MAIL, -,  FROM:<it AT meinefqdn.de>,
    192.168.192.123, ASSP.local, 21.06.2011, 08:20:45, SMTPSVC1, S1, 192.168.192.123, 10, 64, 33, 250, 0, RCPT, -,  TO:<info AT meinefqdn.de>,
    192.168.192.123, ASSP.local, 21.06.2011, 08:20:45, SMTPSVC1, S1, 192.168.192.123, 40, 4, 46, 240, 170, QUIT, -, ASSP.local,
    192.168.192.123, ASSP.local, 21.06.2011, 08:20:45, SMTPSVC1, S1, 192.168.192.123, 0, 15, 307, 250, 0, EHLO, -,  ASSP.local,
    192.168.192.123, ASSP.local, 21.06.2011, 08:20:45, SMTPSVC1, S1, 192.168.192.123, 0, 22, 27, 250, 0, MAIL, -,  FROM:<>,
    192.168.192.123, ASSP.local, 21.06.2011, 08:20:45, SMTPSVC1, S1, 192.168.192.123, 0, 60, 31, 250, 0, RCPT, -,  TO:<it AT meinefqdn.de>,
    192.168.192.123, ASSP.local, 21.06.2011, 08:20:56, SMTPSVC1, S1, 192.168.192.123, 0, 15, 307, 250, 0, EHLO, -,  ASSP.local,
    192.168.192.123, ASSP.local, 21.06.2011, 08:20:56, SMTPSVC1, S1, 192.168.192.123, 0, 36, 27, 250, 0, MAIL, -,  FROM:<>,
    192.168.192.123, ASSP.local, 21.06.2011, 08:20:56, SMTPSVC1, S1, 192.168.192.123, 0, 60, 31, 250, 0, RCPT, -,  TO:<it AT meinefqdn.de>,
    192.168.192.123, ASSP.local, 21.06.2011, 08:20:56, SMTPSVC1, S1, 192.168.192.123, 10916, 6923, 134, 250, 0, DATA, -,  <20110621062045.ADC941A3653BE AT fmmailgate02.web.de>,
    192.168.192.123, ASSP.local, 21.06.2011, 08:20:56, SMTPSVC1, S1, 192.168.192.123, 0, 4, 61, 240, 11086, QUIT, -, ASSP.local,
    192.168.192.123, ASSP.local, 21.06.2011, 08:20:56, SMTPSVC1, S1, 192.168.192.123, 661, 1598, 103, 250, 0, DATA, -,  <VR4e003840 AT web.de>,
    192.168.192.123, ASSP.local, 21.06.2011, 08:20:56, SMTPSVC1, S1, 192.168.192.123, 0, 4, 61, 240, 1232, QUIT, -, ASSP.local,
    Code:
    2. Log vom [ASSP Relay SMTP Virtual Server auf Exchange 2003]
    
    192.168.192.123, ASSP.local, 21.06.2011, 08:20:41, SMTPSVC2, S1, 192.168.192.123, 0, 15, 307, 250, 0, EHLO, -,  ASSP.local,
    192.168.192.123, ASSP.local, 21.06.2011, 08:20:41, SMTPSVC2, S1, 192.168.192.123, 0, 13, 22, 0, 0, x-exps, -,  GSSAPI,
    192.168.192.123, ASSP.local, 21.06.2011, 08:20:41, SMTPSVC2, S1, 192.168.192.123, 10, 140, 68, 200, 0, x-link2state, -,  LAST CHUNK={0000006a} MULTI (5) ({00000051} DIGEST_QUERY 32c553cfde95fd4d8a6c68d1dc04baab d8e1d9c163a2acb2f9f0de515e0e5287  )  ,
    192.168.192.123, ASSP.local, 21.06.2011, 08:20:41, SMTPSVC2, S1, 192.168.192.123, 10, 30, 43, 250, 0, MAIL, -,  FROM:<it AT meinefqdn.de>,
    192.168.192.123, ASSP.local, 21.06.2011, 08:20:41, SMTPSVC2, S1, 192.168.192.123, 0, 65, 39, 250, 0, RCPT, -,  TO:<meine.email AT web.de>,
    192.168.192.123, ASSP.local, 21.06.2011, 08:20:41, SMTPSVC2, S1, 192.168.192.123, 440, 2934, 137, 250, 0, DATA, -,  <E146B2C65166FF4E82295F45E34A76A614C174 AT s1.vhs.local>,
    192.168.192.123, ASSP.local, 21.06.2011, 08:20:41, SMTPSVC2, S1, 192.168.192.123, 0, 4, 61, 240, 812, QUIT, -, ASSP.local,
    212.172.221.8, OutboundConnectionResponse, 21.06.2011, 08:20:41, SMTPSVC2, S1, -, 20, 0, 49, 0, 0, -, -, 220 sydney.webhoster.ag ESMTP sydney.webhoster.ag,
    212.172.221.8, OutboundConnectionCommand, 21.06.2011, 08:20:41, SMTPSVC2, S1, -, 20, 0, 4, 0, 0, EHLO, -, s1.vhs.local,
    212.172.221.8, OutboundConnectionResponse, 21.06.2011, 08:20:41, SMTPSVC2, S1, -, 30, 0, 23, 0, 0, -, -, 250-sydney.webhoster.ag,
    212.172.221.8, OutboundConnectionCommand, 21.06.2011, 08:20:41, SMTPSVC2, S1, -, 30, 0, 4, 0, 0, AUTH, -, -,
    212.172.221.8, OutboundConnectionResponse, 21.06.2011, 08:20:41, SMTPSVC2, S1, -, 50, 0, 16, 0, 0, -, -, 334 UGFzc3dvcmQ6,
    212.172.221.8, OutboundConnectionResponse, 21.06.2011, 08:20:41, SMTPSVC2, S1, -, 70, 0, 35, 0, 0, -, -, 235 2.0.0 Authentication successful,
    212.172.221.8, OutboundConnectionCommand, 21.06.2011, 08:20:41, SMTPSVC2, S1, -, 70, 0, 4, 0, 0, MAIL, -, FROM:<it AT meinefqdn.de> SIZE=3185,
    212.172.221.8, OutboundConnectionResponse, 21.06.2011, 08:20:41, SMTPSVC2, S1, -, 90, 0, 12, 0, 0, -, -, 250 2.1.0 Ok,
    212.172.221.8, OutboundConnectionCommand, 21.06.2011, 08:20:41, SMTPSVC2, S1, -, 90, 0, 4, 0, 0, RCPT, -, TO:<meine.email AT web.de> NOTIFY=SUCCESS,FAILURE,DELAY,
    212.172.221.8, OutboundConnectionResponse, 21.06.2011, 08:20:41, SMTPSVC2, S1, -, 100, 0, 12, 0, 0, -, -, 250 2.1.5 Ok,
    212.172.221.8, OutboundConnectionCommand, 21.06.2011, 08:20:41, SMTPSVC2, S1, -, 100, 0, 4, 0, 0, DATA, -, -,
    212.172.221.8, OutboundConnectionResponse, 21.06.2011, 08:20:41, SMTPSVC2, S1, -, 110, 0, 35, 0, 0, -, -, 354 End data with <CR><LF>.<CR><LF>,
    212.172.221.8, OutboundConnectionResponse, 21.06.2011, 08:20:41, SMTPSVC2, S1, -, 130, 0, 37, 0, 0, -, -, 250 2.0.0 Ok: queued as 012B415E9000D,
    212.172.221.8, OutboundConnectionCommand, 21.06.2011, 08:20:41, SMTPSVC2, S1, -, 140, 0, 4, 0, 0, QUIT, -, -,
    212.172.221.8, OutboundConnectionResponse, 21.06.2011, 08:20:42, SMTPSVC2, S1, -, 150, 0, 13, 0, 0, -, -, 221 2.0.0 Bye,
    Was kann ich hier machen, damit ich "No Spoofing Allowed" Meldung nicht mehr bekomme ?

    Gruss Hassan

  2. #2
    Mitglied
    Registriert seit
    06.10.2008
    Ort
    Rhein-Main Gebiet
    Beiträge
    122

    Standard

    ich benutze selber ASSP, der meldet "No Spoofing Allowed" wenn jemand mit einer lokalen Adresse von aussen ohne Authentifizierung einliefern will.

    Anscheinend hält web.de Deine Absenderadresse für eine lokale Adresse.

    Wer ist den der Domain Provider? Ist da ein SPF Record gesetzt?

    Die meisten der großen Mailhoster akzeptieren nichts von dynamischen IPs (kein Wunder). Das vhs.no-ip.info dürfte fast überall ein KO Kriterium sein. Wie siehts denn mit Hotmail, Yahoo u.ä. aus? Nehmen die Mails von Dir an?

    Du hast eine dynamische dip0.t-ipconnect.de IP, da würde ich normalerweise auch nichts von haben wollen :-((

  3. #3
    Neues Mitglied
    Registriert seit
    20.06.2011
    Beiträge
    2

    Daumen hoch gelöst:

    Hallo nospamplease,

    Die IP ist nicht von dip0.t-ipconnect.de, sondern von Kabel BW. Es könnte jedoch sein, das die wiederrum einen Range von der Telekom haben

    Das Problem der dynamischen IP Adresse habe ich oben ja bereits sauber beschrieben. Bei Kabel BW bekommt man keine fest IP Adresse. Von daher habe ich als 1. MX Eintrag den FQDN vhs.no-ip.info setzen lassen (dahinter ist logischweise eine dynamische IP)

    Da ich aber diesen Problem schon hatte, bevor ich ASSP vor über 2 Jahren aufgesetzt habe, und damals die Lösung bei Exchange der Versand über den authentifizierten Smarthost war (was dann der 2. MX meines Mailproviders ist), hat es mich jetzt doch gewundert. Da eigentlich der letzte Schritt hier gleich blieb.

    Mir ist jedoch etwas komisches aufgefallen !!!

    Meine Frau hat ebenfalls eine web.de Email. Also habe ich Ihr mal eine Testmail geschickt. Und hier habe ich von web.de keine "No Spoofing Allowed" Antwort erhalten.

    Also habe ich mal meinen web.de Account durchforstet und folgendes festgestellt.

    Ich hatte eine Weiterleitung der web.de Email an meinen anderen auf dem Exchangeserver gehosteten Account eingerichtet. Und zwar auf die "Info AT" Adresse. Versendet hatte ich aber NIE mit der "Info AT" Adresse.

    Nachdem ich die Weiterleitung rausgenommen habe, ist die "No Spoofing Allowed" Meldung nicht mehr gekommen.

    Da ich den web.de Account nur für Aushilfs- und Testzwecke brauche, ist das die Lösung für mich.

    Danke und bis zur nächsten Frage

  4. #4
    Forenbarbar Avatar von alariel
    Registriert seit
    02.03.2007
    Ort
    Hennef
    Beiträge
    3.434

    Standard

    Zitat Zitat von HassanMullah Beitrag anzeigen
    ich betreibe einen kleinen privaten Emailserver auf Basis von Exchange 2003 (SBS 2003).
    Ja, was denn? EMailserver oder Exchange? *SCNR*

    In der Tat kann das ein Spamschutz von Web.de sein - es ist schliesslich äusserst ungewöhnlich, dass from- und to-Domain dieselbe sind - und durch web.de bedient werden sollen. Zumindest - aus Sicht von web.de - durchaus verdächtig.
    Klickibunti, zur Dunklen Seite dieser Weg Dich führt!
    Isediatur ignoratia vestra ac stupitiatae causa!
    Barbar - und stolz darauf!! ~***~ Nam et ipsa scientia potestas est!

  5. #5
    Mitglied
    Registriert seit
    06.10.2008
    Ort
    Rhein-Main Gebiet
    Beiträge
    122

    Standard

    Ich hatte eine Weiterleitung der web.de Email an meinen anderen auf dem Exchangeserver gehosteten Account eingerichtet. Und zwar auf die "Info AT" Adresse. Versendet hatte ich aber NIE mit der "Info AT" Adresse.
    Dann ist das kein Wunder, ASSP lehnt als default Mails mit einer lokalen Domain von aussen mit der Meldung "No Spoofing Allowed" ab. Die hat Dein ASSP an Web.de zurückgereichht und web.de dann wieder an Dich.

    Wundert mich trotzdem, das web.de überhaupt Mails von einer dynamischen IP annimmt.

Lesezeichen

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •  
Partnerlink:
REDDOXX Anti-Spam Lösungen